Revision history for MythTV


Revision [262]

Last edited on 2012-02-13 18:31:04 by OllaAdmin
Additions:
||mythbackend||master||configured & running, autostart@boot||{{color text="green" c="green"}}||
||mythfrontend||master||configured & running, autostart@boot||{{color text="green" c="green"}}||
||mythfrontend||slave on MAC mini||installed & running, crashes from time to time||{{color text="amber" c="yellow"}}||
====Mythvideo====
====Mytharchive====
Deletions:
||mythbackend||master||conigured & running, autostart@boot||{{color text="green" c="green"}}||
||mythfrontend||master||conigured & running, autostart@boot||{{color text="green" c="green"}}||
||mythfrontend||slave on MAC mini||insstalled & running, crashes from time to time||{{color text="amber" c="yellow"}}||
====Myhtvideo====
====Myhtarchive====


Revision [261]

Edited on 2012-02-13 18:27:35 by OllaAdmin
Additions:
||Update||Update to 0.24.2 ||pending ||{{color text="gray" c="gray"}}||
Deletions:
|| || || ||{{color text="gray" c="gray"}}||


Revision [249]

Edited on 2011-10-21 23:27:37 by OllaAdmin
Additions:
This solution requires a mount -a after every boot at the moment. I'm not enough of a Linux geek to know the reason yet. Mr Google was no help neither.


Revision [247]

Edited on 2011-10-13 14:01:26 by OllaAdmin
Additions:
||mythfrontend||slave on MAC mini||insstalled & running, crashes from time to time||{{color text="amber" c="yellow"}}||
Deletions:
||mythfrontend||slave on MAC mini||not started yet||{{color text="gray" c="gray"}}||


Revision [230]

Edited on 2011-06-13 21:32:18 by OllaAdmin
Additions:
||PVR-350 x2||OpenSuSE autodetected||2x running with ivtv, some recordings are dropped||{{color text="amber" c="yellow"}}||
Deletions:
||PVR-350 x2||OpenSuSE autodetected||2x running with ivtv, some recordings are dropped||{{color text="amber" c="amber"}}||


Revision [229]

Edited on 2011-06-13 21:31:34 by OllaAdmin
Additions:
||PVR-350 x2||OpenSuSE autodetected||2x running with ivtv, some recordings are dropped||{{color text="amber" c="amber"}}||
Deletions:
||PVR-350 x2||OpenSuSE autodetected||2x running with ivtv, some recordings are dropped||{{color text="orange" c="orange"}}||


Revision [228]

Edited on 2011-06-13 21:30:53 by OllaAdmin
Additions:
||PVR-350 x2||OpenSuSE autodetected||2x running with ivtv, some recordings are dropped||{{color text="orange" c="orange"}}||
||MythVideo|| ||ok||{{color text="green" c="green"}}||
||MythArchive||-||tested, ok||{{color text="green" c="green"}}||
Deletions:
||PVR-350||OpenSuSE autodetected||2x running with ivtv||{{color text="green" c="green"}}||


Revision [227]

Edited on 2011-06-13 21:28:07 by OllaAdmin
Additions:
||mythfrontend||slave on MAC mini||not started yet||{{color text="gray" c="gray"}}||
|| || || ||{{color text="gray" c="gray"}}||
|| || || ||{{color text="gray" c="gray"}}||
Deletions:
||mythfrontend||slave on MAC mini||not started yet||{{color text="gray" c="grey"}}||
|| || || ||{{color text="gray" c="grey"}}||
|| || || ||{{color text="gray" c="grey"}}||


Revision [226]

Edited on 2011-06-13 21:26:46 by OllaAdmin
Additions:
||mythfrontend||master||conigured & running, autostart@boot||{{color text="green" c="green"}}||
||mythfrontend||slave on MAC mini||not started yet||{{color text="gray" c="grey"}}||
||PVR-350||OpenSuSE autodetected||2x running with ivtv||{{color text="green" c="green"}}||
|| || || ||{{color text="gray" c="grey"}}||
|| || || ||{{color text="gray" c="grey"}}||
Deletions:
||mythfrontend||master||conigured & running, autostart@boot||green||
||mythfrontend||slave on MAC mini||not started||grey||


Revision [225]

Edited on 2011-06-13 21:24:03 by OllaAdmin
Additions:
===Status===
Status of my productive system:
|=|module|=|comment|=|status|=|color|=|
||mythbackend||master||conigured & running, autostart@boot||{{color text="green" c="green"}}||
||mythfrontend||master||conigured & running, autostart@boot||green||
||mythfrontend||slave on MAC mini||not started||grey||


Revision [219]

Edited on 2011-06-06 13:28:09 by OllaAdmin
Additions:
nvidia-xconfig
re-start xwindows
-> TwinView
-> clone Screen & TV
Deletions:
TwinView
clone Screen & TV


Revision [218]

Edited on 2011-06-06 11:39:38 by OllaAdmin
Additions:
====MythTV 0.24====
start MySQL in yast runlevel editor
http://www.mythtv.org/docs/mythtv-HOWTO-6.html#ss6.2
Set Sound output to the correct device!
===XMLTV===
==prereqs==
Deletions:
===MythTV 0.24===
====XMLTV====
===prereqs===


Revision [217]

Edited on 2011-06-06 11:36:38 by OllaAdmin
Additions:
This is the Documentation of my MythTV installation on OpenSuSE.
====MythTV 0.24 Installation====
connect software repository PackMan
Check MySQL installed, true
ivtv installed, true
Sound configured --> yast, true
TV cards configured --> yast, true
===nVidia Video===
installed the nvidia proprietary drivers from nvidia repository:
only the failsave boots :(
http://en.opensuse.org/SDB:NVIDIA_the_hard_way
The latest nvidia driver has a bug with my TV card:
http://www.nvnews.net/vbulletin/showthread.php?t=162041
Desktop effects cause a problem, disabling them solves it.
terminal:
nvidia-settings
TwinView
clone Screen & TV
After adding my second TV card, SuSE booted without X-Windows. Disabling the gfx mode in the boot-loader (remove vga=0x318) solved the problem.
Problem unclear, but it works.
===Mapping remote resources===
==Accessing videos==
%%
mount -a
%%
===VNC setup===
I tried activating the Desktop Remote Help:
%%(language-ref)
Anwendungen->System->Verbindung zu Fremdrechnern->Arbeitsfläche freigeben (Krfb)->Menu: Einstellungen->Freigabe der Arbeitsfläche einrichten-> +Uneingeladene Verbindungen akzeptieren, -vor dem Verbinden nachfragen, Passwort
%%
--> random success in sharing display:0 , having a new session worked. Very slow reaction, poor quality.
after reading some forum entries I installed x11vnc trough yast
http://www.karlrunge.com/x11vnc/
I was able to connect to display:0 now but it was all black, the faq suggested:
%%(language-ref)
linux:/> x11vnc -chvt 1
%%
Autostart for KDE:
http://www.linjux.org/blog/2010/07/kurztip-bestehende-x-session-mit-vnc.html
joe ~/.kde4/Autostart/x11vnc
%%(language-ref)
#!/bin/bash
/usr/bin/x11vnc -httpdir /usr/share/vnc/classes -httpport 5902 -display :0 -noxdamage -ultrafilexfer -display :0 -forever -shared -usepw
%%
chmod 755 ~/.kde4/Autostart/x11vnc
--> done.
===MythTV 0.24===
Mythtv24
install mythtv_24 packages (all) from PackMan
====XMLTV====
===prereqs===
http://wiki.xmltv.org/index.php/Main_Page
http://sourceforge.net/projects/xmltv/
zypper install make
perl -MCPAN -e 'install XML::Twig'
perl -MCPAN -e 'install XML::Writer'
perl -MCPAN -e 'install Date::Manip' --> fails
zypper install perl-DateManip
===Install===
make
make test
make install
--> OK
===Mythfilldatabase===
configure fails:
perl -MCPAN -e 'install File::Slurp'
perl -MCPAN -e 'install HTML::TreeBuilder'
mythtv-setup
ran configure in mythtv-setup
manually added frequencies
manually start backend & frontend
can tune live TV now! But exits to black screen... --> Fixed, wrong sound config caused that error.
====Myhtbackend Start at runlevel 3, 5====
The RPM from packman
http://packman.links2linux.org/package/mythtv-0_24
preconfigures mythbackend in the yast runlevel editor. However some config files are missing and the automatic start fails.
Adding the file /etc/sysconfig/mythbackend with this content solves the problem:
%%(language-ref)
## Path: /etc/sysconfig/mythbackend
## Description: Basic configuration for the mythTV backend
## Type: string
## Default ""
#
# default options for the mythTV backend
#
MYTHBACKEND_OPTIONS=""
## Type: string
## Default "mythbackend"
#
# The mythTV backend should run as unprivileged user, if possible
#
MYTHBACKEND_USERID="mythtv"
## Type: string
## Default "video"
#
# The mythTV backend should run as unprivileged group, if possible
#
MYTHBACKEND_GROUPID="video"
## Type: string
## Default "~$MYTHBACKEND_USERID"
#
# The mythTV backend should run as unprivileged user, if possible
#
MYTHBACKEND_HOME=""
%%
====Myhtvideo====
After setting up the sources:
Press 'M' to update videos view...
====Myhtarchive====
ERROR: Failed while running jpeg2yuv - jpeg2yuv -n 375 -v0 -I p -f 25 -j '/home/tmp/mytharchive/work/background-1.jpg' | mpeg2enc -b 5000 -a 2 -v 1 -f 8 -o '/home/tmp/mytharchive/work/temp.m2v'
mjpegttools was installed acc. to yast but a
sudo zypper install mjpegtools-2.0.0-1.pm.1.1.i586
fixed the problem!
Deletions:
This is the Documentation of my MythTV installation.
nVidia video drivers
Mapping remote resources
===Install-log===
[Mythtv24]
===Accessing videos===


Revision [216]

Edited on 2011-06-06 11:25:43 by OllaAdmin
Additions:
===PreRequisites===
OpenSuSE 11.4
nVidia video drivers
Mapping remote resources


Revision [215]

Edited on 2011-06-05 16:29:41 by OllaAdmin
Additions:
//x.x.x.x/Daten/video /videos cifs username=user,password=pw,_netdev 0 0
Deletions:
//x.x.x.x/Daten/video /videos cifs user=user,password=pw


Revision [204]

Edited on 2011-05-29 10:36:40 by OllaAdmin
Additions:
//x.x.x.x/Daten/video /videos cifs user=user,password=pw
Deletions:
//x.x.x.x/Daten/video /videos cifs username=user,password=pw,_netdev 0 0


Revision [196]

Edited on 2011-05-18 21:29:04 by OllaAdmin
Additions:
===Accessing videos===
Deletions:
===Video===


Revision [193]

Edited on 2011-05-15 20:50:05 by OllaAdmin
Additions:
su
mkdir /videos
(mount -t cifs -o username=user,password=pw //x.x.x.x/Daten/video /videos)
joe /etc/fstab
//x.x.x.x/Daten/video /videos cifs username=user,password=pw,_netdev 0 0


Revision [192]

Edited on 2011-05-15 19:49:37 by OllaAdmin
Additions:
===Install-log===
[Mythtv24]


Revision [82]

Edited on 2010-10-16 21:02:56 by OllaAdmin
Additions:
===Video===
mapping of my NAS:
http://opensuse.swerdna.org/susesambacifs.html


Revision [46]

Edited on 2010-10-03 11:25:38 by OllaAdmin
Additions:
my [[MythTVhardware MythTV hardware]]
Deletions:
my MythTVhardware


Revision [45]

Edited on 2010-10-03 11:25:02 by OllaAdmin
Additions:
my MythTVhardware
Deletions:
my [MythTV-hardware]


Revision [44]

Edited on 2010-10-03 11:21:54 by OllaAdmin
Additions:
my [MythTV-hardware]
Deletions:
my [[MythTV-hardware]]


Revision [43]

Edited on 2010-10-03 11:21:36 by OllaAdmin
Additions:
my [[MythTV-hardware]]
Deletions:
my MythTV-hardware


Revision [42]

Edited on 2010-10-03 11:20:31 by OllaAdmin
Additions:
my MythTV-hardware


Revision [30]

The oldest known version of this page was created on 2010-10-01 17:16:52 by OllaAdmin
Valid XHTML :: Valid CSS: :: Powered by OllaWiki